help - menu > file
  1. File
    1. New Project
    2. Open Project
    3. MRC File
    4. Movie File
    5. Save Project
    6. Save As
    7. Recent
    8. Project
      1. Volume setting
      2. Scale bar
      3. Specifies ratio of the Z-axis direction
    9. Export
      1. SVG Export
      2. Image Export
    10. Export IMOD
    11. Export Movie
    12. Export Node
  2. Exit

File



New Project


Overview
You can create a new project.

Detail
Reading multiple images like jpg, bmp, png, tif and so on, You can create a new project.
You should have to read same type and same size images at a time.

▲top

MRC File


Overview
Loading MRC format image data handled in IMOD.
When loading 16bit data, it convert to 8bit data because internally it is treated as a black and white 8bit.

File → New Project → MRC File 



Please select a .mrc file, image is displayed.


▲top


Movie File

Overview
Make new project from movie.

Movie File

Detail
Create new project by loading movie file (avi, mpg).
You can set whether read all frame or by skipping.
Depending on video codec to read, it may not be read in optimal number of frames.
Movie codecs,we recommend such as MPEG-1.

▲top

Open Project


Overview
You can open an existing project.

Detail
You can open a HawkC project file whose extension is "hkc".
If you delete the contents of the folder or quit the program forcibly while saving, the project file might be damaged and you could not open it correctly.

▲top

Save Project


Overview
You can wholly save an project.

Detail
If you are editing a new project, you can save it with new name.
The projects include the folder "volume", the folder "plugin" and the file ".hkc".
If you rename these folders, you could not open the projects correctly.

▲top

Save As


Overview
You can save an existing project with another name.

Detail
You can save an opened project with another name.
The projects include the folder "volume", the folder "plugin" and the file ".hkc".
If you rename these folders, you could not open the projects correctly.

▲top

Recent


Overview
You can see the recently-opened "hkc" projects list.

Detail
The list shows the latest  projects up to ten.
The list will be updated when you open or save the projects.

▲top

Project


Volume setting


Overview
You can change the actual size of the images.



Detail
You can designate the actual unit of the images. You can choose the unit from "pm", "nm", "μm", "mm", "cm", "m" and "Å".
You can choose the way from two. One is to designate horizontal, vertical and height. And the other is to designate size per 1 voxel.
You can designate size from minimum 0.001pm to maximum 9999m.



▲top

Scale bar


Overview
Scale bar is displayed in lower right corner by specifying in dialog to set physical quantity and ratio.

 Please select File→ Properties→ change, check visible of scale bar.



Scale bar is displayed in lower right corner.



▲top

Specifies ratio of the Z-axis direction


Overview
How to specify ratio of the Z-axis direction.

File -> Project -> Property, and then click the Change button in "RzPropertyDialog" window.




Please change the ratio of the Z-axis at size setting window.

context menu


You can check and compare the case of Ratio 3.0 and Ratio 1.0 in the 3D viewer, the ratio with respect to the Z-axis is actually modified.

context menu
▲top


Export


SVG Export


Overview
You can save the images as vector data.

Detail

You can save the images as SVG format image.
The vector data are saved in the created "SVGExport" folder of the designated folder. By using image editing software, You can edit the curve shapes.
The vector data include only curve data, so you have to use the command "Image Export" as necessary.

▲top

Image Export


Overview
You can save the images as raster image.



Detail

You can save the images as the designated format. You can choose the format from tif, png, bmp and jpg.
When saving, you can choose the exported data from image data and curve data respectively.
The saved curve data are not editable. So you should have to use the command "SVG Export" as necessary.

▲top

Export IMOD


Overview
Outputs the contour information that was created in readable format IMOD in HawkC.

File → Export → Export IMOD
Output contour information in a readable format in IMOD.


▲top

Export Movie


Overview
Output the video, single slice as 1 frame.

Export Movie

Detail;
Save video in avi format.
When saving, you can select individually whether display image and curve or not.
In export settings, there is a compression program that can not be used now. Please refer to writing in the "Microsoft Video 1".
Also, please try to use name of alphanumeric when you want to save.

▲top

Export Nodes


Overview
Output node information of each image.

Export Nodes

Detail
Save node information in CSV format.
The output file contain X, Y, Z coordinates of node, curve ID that includes nodes, and label which can be selected six colors.


▲top

Exit


Overview
You can quit HawkC.

Detail
While extracting contours or doing the others, you can't quit the program until the process is done.
Without saving the project, you might loose the data. So you should have to save the project before quitting.

▲top